Zwave update

This update is now available on new Zigbee hubs, and will later be available on EnOcean hubs.

Z-Wave adapter 1.0.7132

Bug Fixes

  • Fixed Multichannel Associations CC
  • Fixed Version CC reports
  • Fixed User Code reports
  • Fixed get FW version and WUP timer commands
  • Fixed adapter crash during exclusion/inclusion
  • Fixed random crashing on node reports
  • Fixed ZIP high CPU usage
  • Fixed missing reports (some multichannel devices)
  • Fixed setting of WakeUp interval
  • Fixed Missing clear events form water leak detectors
  • Fixed adapter crash on received report
  • Fixed Overheat and Underheat clear messages
  • Removed libssl
  • Removed libcrypto
  • Removed caching of reports (causing adapter to crash)
  • Removed interference with the node interview process
  • Removed DTLS connection
  • Removed report caching from Z-Ware (random crash generator)
  • Removed Battery nodes pooling facility
  • Removed AC/FLIR’s nodes pooling facility

New Features and Improvements

  • Added command to get total numbers of endpoints and nodes
  • Added Door Lock CC Configuration (set, get, report)
  • Added HeatIt Smoke templates
  • Added Version CC service to read sensor SW and HW version data
  • Added Aeotec Smart Switch 7 template
  • Added Futurehome Modeswitch templates
  • Improved logging
  • Refactored Base Class FIMP message handling
  • Upgraded easylogging library
  • Refactored FIMP message processing
  • Initial Set/Get priority routing commands
  • Filtered out MQTT, meter and temperature logs
  • Associations and lifetime set fix (missing report from multichannel devices)
  • Changed API interface(s) to support new Z-Ware
  • Removed DTLS (using 4123 port now)
  • Migration to 7.13.10x Z-Wave Stack

Zipgateway 7.13.108

Fixed Bugs

  • Removed filtering of Multichannel messages with ep > 0 (re-routed to 1)

This release is fixing “missing” reports from Fibaro Dimmer 2, Fibaro Single Switch 2 and other multichannel devices.


4 Likes

Status oppdaterer seg enda ikke for Danalock V3 Z-wave. Kan åpne, uten status endring, men kan ikke låse, hverken app eller modus/automasjon…

@Optimus88 tenker du på at status ikke oppdaterer seg for danalock i appen når du låser opp og igjen, men så er status oppdatert hvis du starter appen på nytt? (slik funker det hos meg)

Ja, men uavhengig av status oppdatering så vil den ikke låse…

Ok Danalock har funka greit her

Vil denne oppdateringen løse et problem jeg har hatt med for mange enheter på ny hub?

Om du tenker på i forhold til at status meldingen er for stor så nei. Jeg kan lage et eget innlegg på det når det er på plass :slight_smile:

Hei! Står at Aeotec Smart switch 7 template lagt til, men denne sliter jeg til med å få til å funke. Bug?