Aqara Smart Plug

Hi, it’s not possible to turn off the smart plug via the app when the type of the device is set as “heater”, why is that?
It’s connected to a heater that I want to turn off remotely. It works if I change type to Light, for example. But then power usage won’t show up under Climate.

1 Like

I don’t think this works. I have the same issue. To get an on off switch you have to set it to something like “appliance” or “light” or “fan” but none of them shows up in the climate energy group.

To get it into the climate group it has to be some kind of temperature control of the device, which I don’t like.

I don’t understand why it has to be predefined like this and we cant choose which energy group each device belongs to.

I run my heaters on their internal thermostat and then I switch them on/off with timers depending on electricity prices.

Right now the only heaters that are possible to turn off are the ones with modes that can be set (e.g. Namron zwave thermostat for heating cables), and that has to be done through Thingsplex.

As to why, I can only guess that when the original interface was designed the assumption was that people would only want their heaters turned down to 5 for freeze protection. Then comes the electricity price madness we have today and that no longer holds true. It’s been asked for before, but what’s possible will depend on the device and it’s API/interface, so I suspect this is more difficult to find a standard for than most assume.


So in this case, it wouldn’t help switching to a different brand smart plug right?

No it doesn’t help.
The problem is in the futurehome system and how it connects the configured device type and the energy groups.

1 Like