Aqara weather sensor stops reporting temperature below 0C

I have been using a Aqara weather sensor as outside temperature. People seem to do this a lot. Mine also worked fine for weeks until winter arrived…
I then noticed they stop sending temperature when it gets colder than 0C.
Humidity and pressure still works fine.
If I take them inside in the house they do not update temperature until I delete them from the system and include them again. Then they work immediately until temperature value goes below zero again.
I have tried 3 different sensors.

Anyone experienced this?

2 Likes

Same here.

Tested by putting one outside. Reported all the way to - 0.3 and after that it only reports humidity and pressure.

2 Likes

Same here, stop at -0,1. humidity and atmospheric is working fine.

1 Like

Same problem with Sonoff temperature sensor

1 Like

Same problem here with aqara worked fine before all the zigbee updates.

Yes, noticed the same myself.
Unfortunately the zigbee updates happened while it still was plus degrees outside so its hard to know in which version it appeared.
To me its seems like a silly programming error

1 Like

I experience exactly the same. I also have tried 3 different sensors. One of the times I tested it, the sensor started working correctly again after I took it inside, without having to delete it first. But at all the other attempts, I had to delete it and include it again before it would start to show temperature updates.

1 Like

I can see now that the problem also applies to philips hue outdoor sensor

I have the same issue with Aqara sensors, it startet after update of Zigbee. It all worked fine last winter. Have also experienced the same with Namron Zigbee Termostat. The temperature fall to -0,1C and the unit stop reporting temperature. Need to remove it and add it, to get it to start reporting temperature again.

1 Like


Have the same issue with 3 sensors:(

1 Like

Is there a way to downgrade zigbee? None of my aqara devices seem to be happy with the update.

This just got strange. I restarted my Hub and now the sensors that are outside in freezing teperatures work again !?
Weird.
You guys might try it also?!

Yes indeed, after reboot I get temperature updates from my aqara sensors again as well. Really strange…

Update
But it seems like I got just one single temperature update per sensor (with a value below 0°C) after rebooting. Afterwards the sensors stop updating again. So rebooting does not solve the problem for me.

Yes and no.
I also had this experience yesterday. Got one new datapoint after reboot. Then nothing.
Rebooted again and got a new datapoint but only from one sensor.
Then I see now that the other one updated in the middle of the night.

So I’m a bit unsure, but it might just be the ordinary very low sample rate of the aqua sensors during constant temperatures.

I had the same here. One sensor was updating right after reboot because temperature changed significally, the other sensors after some time later (temperature change) or when i forced them to send data by pushing the button on the sensor device.
But: every sensor stopped updating after it had sent the first update after reboot. So it looks like the Hub is getting a value < 0°C and then says “Oh, a value < 0°C is not allowed, something is wrong with that device, I’m going to ignore it from now on.” (Just a wild guess though :wink: )

1 Like

Same problem here.

Sorry for the late respons, guys!
This seems to be an issue on our side. We have done and are still doing some fault finding on this topic.
I hope this will be fixed till next Zigbee release.

4 Likes

Any news on this ?

3 Likes

Hi.

I have the exact same problem described in this thread, and thought it was due to the sensor itself.
But after reading this, maybe the hub is the problem?

1 Like