Need testers for the new Mill integration

Hey guys!
During the summer Mill will introduce a new mobile application. Using it would require the users to migrate to a new cloud, which affects our existing integration. Do we have any users that have updated, if so how is the integration working with futurehome?

We have made some adjustments in our playground app to handle both scenarios, and therefore are we looking for some testers.
If you would participate in this testing please comment below and we will contact you.

I can join

1 Like

Open to support with testing as well! :slight_smile:

1 Like

I can support.

I have upgraded to the new App. Devices are visible but show 0 degrees and im unable to control the temperature from FH after upgrade. Tried both to reinstall the Playground App and the Mills App on my phone.

2 Likes

We will start testing right after the summer holidays. You will be contacted :slight_smile:

1 Like

Bidrar gjerne. Har Mill v2 og v3. Tar gjerne også en titt på koden :slight_smile:

I’m happy to contribute if needed. When is “after summer” though? Right now I’m unable to control any of my Mill wifi sockets through FH due to the update. I updated the Mill-app and disconnected/reconnected Mill in Playground - which made the units non-existing in FH. Would be great to know if I need to revert to the Mill app to control these now and for how long?

I can join,
Migrated my Mill’s this week and can no longer control them.

I can also join, recently bought a Mill Wifi Smart Socket and have tried controlling it from Futurehome. Whatever I do, app status is active/running, auth status: authenticated, config status: not_configured, and connection status: disconnected.

Hi again. We are soon ready to onboard you to the beta version. I have gathered which site to be installed on, except two of you that was owner on multiple sites. I have sent you a message here on the forum asking which sites you want to proceed with testing.

We are sorry that this have taken a bit longer time than expected.

2 Likes

I can join in testing as well :slight_smile:

1 Like

I can join as well but I have a few questions.

@generat0ren what are your questions? :slight_smile:

Hei Espen,

Har en Mill Glass panelovn 3.gen. 1300w. Jeg skal være borte fra søndag i 2 uker. Så spørsmålene er:

  1. Burde jeg være hjemme og fysisk sjekke temperaturer osv. (og evt. kontrollere endrede innstillinger) ved ny integrasjon? Blir vel kanskje litt blind uten å sjekke fysisk.
  2. Er det bare en ny beta-integrering mot Mill i den vanlige FH-appen, i tillegg til den vanlige Mill-integreringen på Playground? Eller må jeg laster ned en egen beta-FH-app, i tillegg til den vanlige appen?
  3. Og kan jeg avslutte beta-integrasjonen/appen uten at det blir mye styr og krøll og må «rydde opp» (bortsett fra å slette beta-integrasjonen/appen, og laste inn backupen igjen)?

Hey again (users with gen2, that have not migrated on mill-side)!

Is there anyone with gen2 devices here?
Are you able to set a new set-point from futurehome, and the same temperature is displayed in fh-app, mill-app and on the heater itself?

Hi @espen! All my Mill devices are Gen2, however I’m not sure if I have been migrated yet​:face_with_peeking_eye:. I have had no notification about this from Mill​:shushing_face:. Only thing I can find is that my Mill app version is 4.3.22. :sweat_smile:

Hi @Tobba, are you able to set a new set-point from futurehome, and the same temperature is displayed in fh-app, mill-app and on the heater itself?

Yes, all responds as expected. Changes are managed with standard time based automations.




Continuing the discussion from Need testers for the new Mill integration:

Hei - jeg har nettopp lagt inn mine Millovner på nytt etter at de sluttet å fungere. Nå viser alle 0 grader. Det er både 2. og 3. generasjons ovner. Har du et triks for å få det til. Vedlagt snag er ett eksempel

I have gen 2 devices and updated the Mills App

Unable to change anything, they are only coming up as “off”. If I turn them to heat and change the setpoint they simply jump back after a while. And report temperature 0.